Annonce

Forum fermé : le support est désormais assuré sur Debian-Facile

HandyLinux rejoint Debian-FacileTous les détails sur le Blog !

Vous n'êtes pas identifié(e).

#1 2015-09-14 13:08:46

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

[Clos] Compiz - Emerald

salut à tous;
je viens de faire une session compiz qui fonctionne à peu près.
le problème que je rencontre se trouve au niveau de la première page de la configuration de compiz (ccsm)
je peux acceder et modifier les paramètres seulement en lisant les notifications... lorsqu'un onglet de configuration est séléctionné l'affichage est correct...
c'est un peu dur à expliquer hein ... ?
voici l'illustration:
1442232324.png
Et les erreurs lorsque je lance via le terminal:

ccsm
Info: No sexy-python package found, don't worry it's optional.
Backend     : ini
Integration : true
Profile     : default
Adding plugins
Initializing core options...done
/usr/lib/pymodules/python2.7/ccm/Utils.py:209: GtkWarning: Failed to set text from markup due to error parsing markup: Erreur à la ligne 1, caractère 140 : L'élément « markup » a été fermé, mais l'élément actuellement ouvert est « br »
  self.Warning.set_markup(self.Markup % value)
Loading icons...
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Initializing firepaint options...done
Initializing mousepoll options...done
Initializing wall options...done
Initializing move options...done
Initializing annotate options...done
Initializing animationaddon options...done
Initializing animation options...done
Initializing regex options...done
Initializing reflex options...done
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Initializing resize options...done
Initializing decoration options...done
Initializing commands options...done
Initializing vpswitch options...done
Initializing place options...done
Initializing shift options...done
Initializing ezoom options...done
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/ccm/Utils.py", line 186, in do_expose_event
    ret = super (PrettyButton, self).do_expose_event (self, event)
RuntimeError: maximum recursion depth exceeded while calling a Python object

Si quelqu'un à une idée merci d'avance; là c'est configurable mais pas très cofortable...

Hors ligne

#2 2015-09-14 13:30:29

arpinux
Administrateur
Inscription : 2015-03-03
Messages : 5 223
Site Web

Re : [Clos] Compiz - Emerald

salut smile

et en changeant de thème gtk pour voir ?

Hors ligne

#3 2015-09-14 13:42:26

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

'lut wink
mwais déjà essayé  cancel  hmm

Hors ligne

#4 2015-09-14 14:00:18

arpinux
Administrateur
Inscription : 2015-03-03
Messages : 5 223
Site Web

Re : [Clos] Compiz - Emerald

un coup pour rien... play again...

ils viennent d'où tes paquets compiz, de nos dépôts ?

Hors ligne

#5 2015-09-14 15:21:29

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

oui oui ils viennent d'ici  wink Merci de les avoir mis au chaud  big_smile

Dernière modification par ragamatrix (2015-09-14 15:25:56)

Hors ligne

#6 2015-09-14 15:28:29

arpinux
Administrateur
Inscription : 2015-03-03
Messages : 5 223
Site Web

Re : [Clos] Compiz - Emerald

ah oki, parce que la compatibilité avec Jessie est toute aléatoire en fait.
j'avais mis ce dépôts en place pour wheezy, et je n'ai rien trouvé d'équivalent à intégrer pour Jessie hmm

Hors ligne

#7 2015-09-14 15:45:38

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

j'ai ajouté le dépot.
j'ai fais update.
séléctionné ce qui ne cassait pas.
installé compiz-core deskmenu emerald et ses dependances fait la session tout seul comme un grand... toussa mais pas ceux de HL car je suis en testing... et ça passait pas (à cause de lxappearance je crois). aussi trouvé le compiz-logout sur le fofo #! quand on bidouillait avec manon.
effacé le dépot après avoir install ça (pour upgrader sans tout casser) en faisant bien gaffe... et voilà  big_smile

Dernière modification par ragamatrix (2015-09-14 15:48:22)

Hors ligne

#8 2015-09-14 15:51:36

arpinux
Administrateur
Inscription : 2015-03-03
Messages : 5 223
Site Web

Re : [Clos] Compiz - Emerald

bien joué smile

mais j'ai pas de soluce pour ton défaut d"interface...

Hors ligne

#9 2015-09-14 16:00:41

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

pas grave pour l'instant, une fois compiz parametré on ne s'en sert plus si souvent de cet interface après. Je peux quand même le faire avec les notifications. Je vais essayer avec d'autres themes gtk....

Hors ligne

#10 2015-09-14 16:58:01

tititopher68
Invité

Re : [Clos] Compiz - Emerald

Bonjour Ragamatrix,

help
Je suis très intéressé par l'installation de Compiz (même si pour la configuration ce n'est pas le top) notament pour les fonctions d'accessibilité visuelle comme le ZOOM - Voir ma présentation dans la rubrique dédiée. N'étant pas très expérimenté avec toutes les commandes en ligne, te serais-t-il possible de me (nous) faire une petit topo pour cette installation.

A l'avance, un grand merci pour tous nos amis déficients visuels.... merci

NB : il existe ce site : http://wiki.compiz.org/Installation/Development doc

Il est dit qu'il est possible de recompiler une version complète de COMPIZ pour n'importe quelle distribution....(?), la dernière version stable serait la 0.9.5.92

#11 2015-09-14 17:05:02

arpinux
Administrateur
Inscription : 2015-03-03
Messages : 5 223
Site Web

Re : [Clos] Compiz - Emerald

re smile
dès que je chope 15 jours de rab', je vous fais ça tongue

Hors ligne

#12 2015-09-15 09:52:48

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

tititopher68 a écrit :

Bonjour Ragamatrix,

help
Je suis très intéressé par l'installation de Compiz (même si pour la configuration ce n'est pas le top) notament pour les fonctions d'accessibilité visuelle comme le ZOOM - Voir ma présentation dans la rubrique dédiée. N'étant pas très expérimenté avec toutes les commandes en ligne, te serais-t-il possible de me (nous) faire une petit topo pour cette installation.

A l'avance, un grand merci pour tous nos amis déficients visuels.... merci

NB : il existe ce site : http://wiki.compiz.org/Installation/Development doc

Il est dit qu'il est possible de recompiler une version complète de COMPIZ pour n'importe quelle distribution....(?), la dernière version stable serait la 0.9.5.92

Salut tititopher68;
Je suis sur une debian "testing" j'ai utilisé les dépots de compiz dispos pour HandyLinux(mon cas est donc un peu différent).
Si tu es sur une version de HandyLinux peut-être peux-tu essayer de t'inspirer de cette excellente documentation compiz par contre fais bien attention de ne rien casser...(ne fais pas les commandes d'install dans le terminal, mais regarde d'abord avec synaptic si rien ne casse)
Avant de faire ça attends une confirmation de quelqu'un plus expérimenté que moi... qui postera ci-dessous

Tu ajoutes les dépots dans le "sources.list"comme dans la doc, ensuite tu update (mais surtout pas upgrade)

sudo apt-get update

Le plus simple ensuite serait de verifier avec synaptic si les paquets

handylinux-compiz handylinux-compiz-session

passent (c-a-d pas de carrés rouges)
Si tout est vert je pense que tu peux les installer et suivre la doc pour HL

Sinon reviens en arrière en déséléctionnant les paquets (rouges).
-repare les paquets cassés (dans synaptic)
-update
-ferme synaptc
commente le sources.list avec --> # (avec le terminal)

sudo leafpad /etc/apt/sources.list

la ligne concernant les dépots compiz...
refais:

sudo apt-get update

re-ouvre synaptic pour voire s'il va bien  big_smile
remets à niveau (upgrade)
Si tu as eu les paquets rouges, c'est qu'il y a des problèmes de dépendances et il faudra donc faire plus de choses manuellement comme j'ai du faire pour moi, séléctionner les paquets compiz qui n'ont pas de rapport avec HL faire une session .desktop un script de démarrage de session, un panel... (plus tard je pense, c'est un peu risqué et je ne voudrais pas que les gens cassent leurs distros à cause de moi)  angel

Dernière modification par ragamatrix (2015-09-15 10:07:58)

Hors ligne

#13 2015-09-15 16:48:36

tititopher68
Invité

Re : [Clos] Compiz - Emerald

Bonjour Ragamatrix et merci pour ta réponse.

J'avais déjà essayé....et tout planté (heureusement, je travaille avec un clone de HL sous vmware, ce qui me permet de faire toutes les expériences...en cas de soucis, on efface HL virtuel et on recharge la précédente copie).

J'ai 3 paquets cassés dans Synaptic et non-réparables...

capturedcran-15092015-173011.php

Je n'ai pas assez de compétences pour aller plus loin...Mes espoirs reposent sur Arpinux...

#14 2015-09-15 18:08:34

arpinux
Administrateur
Inscription : 2015-03-03
Messages : 5 223
Site Web

Re : [Clos] Compiz - Emerald

alors pour intégrer compiz chez nous, il faut d'abord que je teste la compilation/installation sur une HandyLinux comme expliqué ici http://wiki.compiz.org/Installation/Development ou là http://wiki.compiz.org/C%2B%2BCompiling ce qui va poser quelques problèmes car nous n'avons pas toutes les dépendances sur Debian Jessie.

vu l'ampleur des tests à réaliser et des ajustements à effectuer, j'aurais besoin d'un peu plus de temps, et en ce moment, je ne peux plus piquer sur mon sommeil pour g33ker, je travaille tôt.

une piste ? http://linuxfreedom-technoshaun.blogspo … an-81.html

Dernière modification par arpinux (2015-09-15 18:11:09)

Hors ligne

#15 2015-09-16 10:18:08

tititopher68
Invité

Re : [Clos] Compiz - Emerald

Bonjour Arpinux,

J'ai testé ce lien. Bilan : Installation de la source (Ubuntu). Recherche et installation des KEY...
J'avais sur Synaptic un seul paquet cassé et non réparable: compiz-fusion-plugins-extra. En fait Compiz est proposé en version 0.9.2 et les plugins Extra en 0.9.8....

Cette installation de Compiz supprime tous les paquets KDE de HL, en remplace un grand nombre et supprime aussi ceux de LibreOffice (?). D'ailleurs la réinstallation de cette dernière par Synaptic ne fonctionne pas. Ce n'est pas vraiment un souci, car en récupérant une 5.01 de LibreOffice sur leur site et en l'installant, c'est tout bon.

J'ai, après l'install de Compiz, lancé le CCSM -> OK pas de soucis d'icônes. On a uniquement les plugins de base dont le zoom. J'ai activé le module pour avoir l'habillage de base des fenêtres et lancement de Compiz par : compiz --replace.
j'ai dû l'exécuter 2 fois pour que cela marche (?) et je n'avais pas l'habillage des fenêtres. Retour dans le CCSM, décocher et recocher la case. Enfin fonctionnel. ZOOM -> OK.

Au redémarrage, on a plus de 1200 mises à jour proposées !!!!!!!!!. Donc un tour dans Sources.list pour désactiver le lien vers ubuntu.

Je n'ai pas essayé d'intégrer Esmerald.

Les plugins extra seraient-ils intégrables via une source en 0.9.2 ?
L'ex paquet Handy Compiz session à modifier (?) pour avoir un lancement simplifié ?

Voilà.

#16 2015-09-16 10:50:30

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

J'ai repéré cette piste, mais les sources compiz que tu as mises dans les dépots HL fonctionnent très bien. Comme je le disais plus haut on peut se faire une session compiz un peu plus manuellement...
Pour que ça fonctionne chez moi je n'ai pas utilisé les paquets prévus pour HL car ils cassaient. Les paquets suivants passent :
1442395660.png
Ensuite j'ai utlisé le panel tint2 (installez-le si vous ne l'avez pas), un fichier .desktop un script d'extinction et un script de lancement autostart-compiz.
En root, dans /usr/share/xsession créez ce fichier .desktop:

sudo leafpad /usr/share/xsession/compiz.desktop

compiz.desktop:

[Desktop Entry]
Encoding=UTF-8
Name=Compiz Standalone
Comment=Log in using the Compiz window manager (without a session manager)
Exec=/usr/bin/compiz-session
TryExec=/usr/bin/compiz-session
Icon=/usr/share/pixmaps/emerald-theme-manager-icon.png
Type=XSession
sudo leafpad /usr/bin/compiz-session

(rendre ce script exécutable propriétés, permissions, et cocher la case autoriser ce fichier à être exécuté comme un programme...)
compiz-session:

#!/bin/sh
## GNOME PolicyKit and Keyring
eval $(gnome-keyring-daemon -s --components=pkcs11,secrets,ssh,gpg) &
## DBUS ##
if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
eval `dbus-launch --sh-syntax --exit-with-session`
fi

## Set root window colour
#hsetroot -solid "#2E3436" &
#gris noir
#hsetroot -solid "#212121" &

nitrogen --restore &

##########################################################################

emerald --replace &
tint2 &
nm-applet &
xfce4-power-manager &

## Start Thunar Daemon
thunar --daemon &

## Adjust the values according to your preferances.
xset r rate 250 25 &
xset m 2 3 &

## Turn on/off system beep
xset b off &

#disable power management
xset -dpms &

## launch WM ##
exec ck-launch-session compiz ccp

toujours dans /usr/bin/ le script d'extinction qu'il faudra rajouter manuellement en éditant le compiz-deskmenu  zen
compiz-logout:

#!/usr/bin/env python

import pygtk
pygtk.require('2.0')
import gtk
import os

class DoTheLogOut:

    # Cancel/exit
    def delete_event(self, widget, event, data=None):
        gtk.main_quit()
        return False

    # Logout
    def logout(self, widget):
        os.system("killall compiz")

    # Reboot
    def reboot(self, widget):
        os.system("dbus-send --system --print-reply --dest=\"org.freedesktop.ConsoleKit\" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Restart")

    # Shutdown
    def shutdown(self, widget):
        os.system("dbus-send --system --print-reply --dest=\"org.freedesktop.ConsoleKit\" /org/freedesktop/ConsoleKit/Manager org.freedesktop.ConsoleKit.Manager.Stop")

    def __init__(self):
        # Create a new window
        self.window = gtk.Window(gtk.WINDOW_TOPLEVEL)
        self.window.set_title("Choisir une operation :")
        self.window.set_resizable(False)
        self.window.set_position(1)
        self.window.connect("delete_event", self.delete_event)
        self.window.set_border_width(20)

        # Create a box to pack widgets into
        self.box1 = gtk.HBox(False, 0)
        self.window.add(self.box1)

        # Create cancel button
        self.button1 = gtk.Button("_Annuler")
        self.button1.set_border_width(10)
        self.button1.connect("clicked", self.delete_event, "Annulation")
        self.box1.pack_start(self.button1, True, True, 0)
        self.button1.show()

        # Create logout button
        self.button2 = gtk.Button("_Deconnecter")
        self.button2.set_border_width(10)
        self.button2.connect("clicked", self.logout)
        self.box1.pack_start(self.button2, True, True, 0)
        self.button2.show()

        # Create reboot button
        self.button3 = gtk.Button("_Redemarrer")
        self.button3.set_border_width(10)
        self.button3.connect("clicked", self.reboot)
        self.box1.pack_start(self.button3, True, True, 0)
        self.button3.show()

        # Create shutdown button
        self.button4 = gtk.Button("_Eteindre")
        self.button4.set_border_width(10)
        self.button4.connect("clicked", self.shutdown)
        self.box1.pack_start(self.button4, True, True, 0)
        self.button4.show()

        self.box1.show()
        self.window.show()

def main():
    gtk.main()

if __name__ == "__main__":
    gogogo = DoTheLogOut()
    main()

voilà...  big_smile
reportez-vous à la doc compiz pour la configuration de celui-ci...
ccsm

Si vous avez un problème avec les cléfs...
J'ai un ptit script sympa  stone

sudo leafpad /usr/bin/cle

cle:

#!/usr/bin/env bash
# Ajouter une clé GPG au porte-cles
# Utiliser gpgkeys pour gérer la suppression
echo "coller la clef (8 caractères)"
read cle
gpg --keyserver pgpkeys.mit.edu --recv-key $cle
gpg -a --export $cle | sudo apt-key add -

n'oubliez-pas de le rendre exécutable...
Vous faites dans un terminal :

sudo apt-get update

et lorque vous voyez votre pb de clef avec le numéro, tapez :

cle

1442397973.png
J'oubliais...
Si vous utilisez slim comme login manager il faudra penser à rajouter votre session "compiz-session" comme expliqué dans la doc d'arpinux... gksudo slimconf (je crois)... Sinon si vous avez un login manager du type lightdm le .desktop sera reconnu automatiquement.

Dernière modification par ragamatrix (2015-09-16 11:22:15)

Hors ligne

#17 2015-09-16 14:48:21

tititopher68
Invité

Re : [Clos] Compiz - Emerald

Hello Ragamatrix,

Merci pour ton post, mais hélas, cela ne passe pas pour moi (en HL 2.2), le paquet Compiz-fusion-plugins-main 0.8.4-2+b1 est toujours indiqué comme cassé et irréparable...
j'ai trouvé ce paquet ailleurs pour une Debian, à l'installation : Gros soucis : suppression de nombreux paquets dont LibreOffice v4.3.3 et au final Distribution HS (pas grave car sous vmware...)

Tu es sur une Debian testing, cela doit être cela je pense...Je vais reprendre le lien posté par Arpinux, prendre tes scripts et essayer d'ajouter Esmerald ainsi que le paquet qui ne passait pas dans cette solution.

Dernière modification par tititopher68 (2015-09-16 14:49:07)

#18 2015-09-16 17:11:58

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

hmm erf vraiment dommage... Je trouve ça bizarre cette histoire de "compiz-fusion-plugins-main 0.8.4-2+b1" si ça passe en testing pourquoi pas en jessie...
c'est bien en tous cas tu as l'air tenace et c'est une grande qualité wink
Bonne chance pour la suite

Hors ligne

#19 2015-09-16 23:51:59

tititopher68
Invité

Re : [Clos] Compiz - Emerald

Hello Ragamatrix,

Effectivement, c'est bizarre mais j'ai vu des posts confirmant le problème sur d'autres sites. J'imagine que tu dois être en SID...

Enfin je te remercie pour tes scripts dont je me suis fortement inspiré, ainsi qu'Arpinux pour la transmission du lien. J'ai pu enfin avoir une session Compiz fonctionnelle sur Handylinux 2.2 J'ai quand même dû me "battre" avec les dépendances et faire une croix sur des applications en conflit avec certaines : Clementine, gParted (remplacée par Partitionmanager KDE), LibreOffice 4.3.3 (remplacée par LibreOffice 5.0.1). J'ai fait une sorte de gestionnaire de session me permettant de passer directement de Compiz à XFCE d'Handyminux et inversement.

Je n'ai pas pu installé Emerald (Compiz est en version 0.9.12 la dernière je crois et les paquets sont cassés pour Jessie), ainsi que les plugins Compiz extra (pour les mêmes raisons). Mais j'ai ce qu'il me faut en terme d'outils d'accessibilité avec cette fonction Zoom et la possibilité de jouer sur les inversions de couleur et contraste.

Je pense que si tu intégrais la version de compiz proposée par Arpinux, tu devrais avoir le ccsm complètement fonctionnel.

Voilà, je sauvegarde le tout et je vais pouvoir proposer et évaluer Handylinux avec mes usagers Déficients Visuels.

J'essaierais de l'installer et l'adapter sur un Orange Pi Plus (35 euros) avec un disque SSD (120 Go à 50 euros), ce serait une solution peu coûteuse pour des non-voyants surtout avec les nouveaux scanners portatifs qui fonctionnent sur batterie et qui sont reconnus à 100% par Handylinux...

Entre 3000,00 euros minimum sous Windows sans le PC et au plus 200,00 euros sous Linux tout compris, il n'y a pas photo...

Dernière modification par tititopher68 (2015-09-16 23:55:45)

#20 2015-09-17 07:23:26

ragamatrix
Membre
Inscription : 2015-08-18
Messages : 276

Re : [Clos] Compiz - Emerald

mwais... je pense qu'il doit y avoir une solution plus propre, qui ne te supprime pas tous ces outils dont tu avais besoin. Il existe une commande terminal pour "filtrer" les paquets  à installer, mais je ne m'en rappelle plus... Je pense qu'il existe une solution, mais il faut beaucoup de patience pour la trouver... neutral Un sources.list bien parametré... ? Et de rien, pour les scripts que j'ai glané à droite et à gauche, je n'ai pas fais grand chose à part partager ces sources, le mérite revient essentiellement à arpinux wink

Dernière modification par ragamatrix (2015-09-17 07:26:09)

Hors ligne

#21 2015-12-02 23:13:11

dyp
[Résolu]-Man
Lieu : Pignan
Inscription : 2015-03-19
Messages : 4 165
Site Web

Re : [Clos] Compiz - Emerald

salut les compizeurs, ça vous dit qu'on mutualise les sujets identiques au lieu d'en ouvrir plein de différents ? celui là a été démarré un peu avant : https://handylinux.org/forum/viewtopic.php?id=1317


dyp Lisez les conseils et astuces du forum pour trouver une solution plus vite. dyp

Hors ligne

#22 2015-12-03 02:40:28

arpinux
Administrateur
Inscription : 2015-03-03
Messages : 5 223
Site Web

Re : [Clos] Compiz - Emerald

re smile
@dyp, c'est bon, je ferme l'autre sujet et on ne garde que celui-là qui est le premier ouvert.
merci, j'avais zappé de fil tongue

++ smile

Hors ligne

#23 2015-12-03 08:07:10

thuban
arpadawan
Inscription : 2015-03-28
Messages : 3 469
Site Web

Re : [Clos] Compiz - Emerald

Coucou smile
Alors résultats de mes recherches pour une handylinux 2-2 : désolé, c'est dans deux liens externes pour le coup comme l'autre fil n'est plus :

- utilisation par compilation : http://yeuxdelibad.net/Blog/?d=2015/12/ … ian-jessie
- utilisation des anciens paquets qu'il y avait sous debian : http://yeuxdelibad.net/Blog/?d=2015/11/ … ian-jessie


YAhacker?A-H

Hors ligne

#24 2016-03-29 12:46:17

pyrouette
Membre
Inscription : 2016-03-13
Messages : 51

Re : [Clos] Compiz - Emerald

Up ^^ On peut installer par des dépots  wink

J'ai installer compiz sur handylinux 2.2  en rajoutant les dépots de compiz

Aucun soucis aucun bug big_smile  juste le paquet desk menu recuperé depot  handy qui n'est pas à jours sinon aucun probleme mrgreen

Ps: une section handyCompiz ? ou un handycompiz serait un plaisir smile

Ou modifier la doc pour l'installer sur handyLinux version jessie Handylinux > 2

Depot

deb http://download.tuxfamily.org/compiz/debian jessie main

Dernière modification par pyrouette (2016-03-29 13:05:54)

Hors ligne

#25 2016-03-29 13:39:42

Starsheep
Mouton étoilé
Inscription : 2015-03-19
Messages : 1 167

Re : [Clos] Compiz - Emerald

Bonjour,

Pour des raisons de sécurité et de stabilité nous déconseillons fortement l'utilisation de dépôts tiers.

Si vous cassez votre système à cause de cela, vous ne pouvez ne vous en tenir qu'à vous même (et vous finirez par pleurer toutes les larmes de votre corps en position fœtale). smile

Hors ligne


⇒ xtra'gifs

Pied de page des forums

Forum ouvert le 03-03-2015 -- Propulsé par FluxBB

HandyLinux, une distribution Debian GNU/Linux sans se prendre la tête
historique du projet -- sources du projet -- avenir du projet